≡ Menu

How to Configure Frame-Relay

Frame-Relay is one of the core concept of networking and nowadays it is one of the under appreciated part on modern networking.

I am just going to go over how to configure it using 4 Routers and one will act as a Frame-Relay cloud.

Before I go ahead and explain the configuration, You can see the below diagram which represents the physical topology.

FRS1

As you can see, FRS is connected via…

Serial 1/1 to R1 Serial 1/0
Serial 1/2 to R2 Serial 1/0
Serial 1/3 to R3 Serial 1/0

Now we have got the physical topology clear, we will move onto Frame-Relay configuration and the DLCI assignment.

FRS2

As you can see the DLCI configuration…

On R1 : DLCI 122 is connected to R2 and DLCI 123 is connected to R3
On R2 : DLCI 221 is connected to R1
On R3: DLCI 321 is connected to R1.

If you are configuring the DLCI then I would suggest you follow this method of numbering, Because from the DLCI Number, I can simply distinguish where the DLCI is connecting to…

For Example, we will take DLCI 122 (One Two Two ) I remember it as; From Router One 2 Two and the same goes for DLCI 321 (Three Two One) Router Three 2 One.

Here are the configuration on the FRS interface(s) config (Please see the first diagram for interface info…) Also please note, you need to add the Global Config command frame-relay switching.

Serial 1/1

interface Serial1/1
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 122 interface Serial1/2 221
frame-relay route 123 interface Serial1/3 321

Serial 1/2

interface Serial1/2
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 221 interface Serial1/1 122

Serial 1/3

interface Serial1/3
no ip address
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
clock rate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 321 interface Serial1/1 123

As you can see, if you are configuring Frame-Relay you should understand what every command does and I will be writing a more detailed post on Frame-Relay switching where all of these commands will be covered.

Now the FRS is set, we will go ahead and configure each interface of the routers R1, R2 and R3.

R1

interface Serial1/0
ip address 172.16.10.1 255.255.255.0
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
no fair-queue
frame-relay map ip 172.16.10.2 122 broadcast
frame-relay map ip 172.16.10.3 123 broadcast
no frame-relay inverse-arp

R2

interface Serial1/0
ip address 172.16.10.2 255.255.255.0
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
no fair-queue
frame-relay map ip 172.16.10.1 221 broadcast
frame-relay map ip 172.16.10.3 221 broadcast
no frame-relay inverse-arp

R3

interface Serial1/0
ip address 172.16.10.3 255.255.255.0
encapsulation frame-relay
logging event subif-link-status
logging event dlci-status-change
no fair-queue
frame-relay map ip 172.16.10.1 321 broadcast
frame-relay map ip 172.16.10.2 321 broadcast
no frame-relay inverse-arp

The most important commands are “Frame-Relay Map” on the Routers and the “Frame-Relay Route” command on the Frame switching router.

As you can see, I have the Broadcast option at the end of the “frame-relay map” command; It is there to allow routing packets such as RIP to be passed through the Frame network. Without this option, it will not allow IP traffic to be switch through frame network.

If you don’t get the DLCI mapping correct, you will not get the circuit to come “active”

You can check the Frame route by issuing the “show frame-relay route” command on FRS.

FRS#sh fr ro
Input Intf   Input Dlci   Output Intf   Output Dlci   Status
Serial1/1    122          Serial1/2     221           active
Serial1/1    123          Serial1/3     321           active
Serial1/2    221          Serial1/1     122           active
Serial1/3    321          Serial1/1     123           active
FRS#

And “show frame-relay map” on the Routers (R1, R2, R3)

R1#sh frame map
Serial1/0 (up): ip 172.16.10.2 dlci 122(0x7A,0x1CA0), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 172.16.10.3 dlci 123(0x7B,0x1CB0), static,
broadcast,
CISCO, status defined, active

R2#sh frame map
Serial1/0 (up): ip 172.16.10.1 dlci 221(0xDD,0x34D0), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 172.16.10.3 dlci 221(0xDD,0x34D0), static,
broadcast,
CISCO, status defined, active

R3#sh frame map
Serial1/0 (up): ip 172.16.10.1 dlci 321(0x141,0x5010), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 172.16.10.2 dlci 321(0x141,0x5010), static,
broadcast,
CISCO, status defined, active

If it says “inactive” or “deleted”, I would first check the DLCI assignment and encapsulation and so forth…

And it is always nice to see the following message…

*Mar  1 00:00:21.005: %FR-5-DLCICHANGE: Interface Serial1/1 - DLCI 122 state changed to ACTIVE
*Mar  1 00:00:21.005: %FR-5-DLCICHANGE: Interface Serial1/1 - DLCI 123 state changed to ACTIVE
*Mar  1 00:00:21.098: %FR-5-DLCICHANGE: Interface Serial1/2 - DLCI 221 state changed to ACTIVE
*Mar  1 00:00:21.146: %FR-5-DLCICHANGE: Interface Serial1/3 - DLCI 321 state changed to ACTIVE

Comments on this entry are closed.

  • Colin Osmond

    Nish,

    I had read lots of sources on this, especially the frame-relay route command, but I just couldn't get my head around it. The DLCI mappings just were not making sense. You explaining it with DLCI "to" DLCI and back again really made it all click into place.

    Thanks very much for doing this.

    • http://www.nish.com Nish Vamadevan

      I’m glad it was able to help you. This is one of those things you wont do as much like a ACL/route-map/prefix-list etc so need to do it a few times to get into the head.

  • Kiran

    Excellent explaination. I was struggling to setup my lab following cisco's documentation. But I found this configuration is far more easier and reliable. Good job mate, keep it up.Thanks and regards,Kiran

    • http://www.nish.com Nish Vamadevan

      Thank you for your comment Kiran.

  • Mike

    Nish,

    You are the man, i have done so many searches but yours is just the best.

    Keep up the great work.

    Thank you and warm regards

    Mike

    • http://www.nish.com Nish Vamadevan

      Thank you Mike, I'm glad you found the post informative.

      • Sandeepdalal2000

         Hi, I did all steps as above mentioned but when i tried #sh fr ro or #sh frame map it shows inactive.Please advice what  i have to do on my cisco 3725 router for frame-relay?

  • Hector

    Thank you very much. I am new to networking and I was able to understand frame relay a lot better now.

  • AbdelRahman

    really perfect explanation.
    I think for the (FRS) router we should enter (frame-relay switching ) command.

    thank you,

    • http://www.nish.com Nish Vamadevan

      I assumed people should have it, but now I have added that to my config.

  • Owais Siddiqui

    Dear Nish,

    I tried to use your step and fallow the configuration that you mention , below is my confgration .. in my case R1-Router link show active all other is showing not active.. kindly help if you can.

    FRS – Configuration
    =================

    default interface Serial0/0/0
    default interface Serial0/0/1
    default interface Serial0/2/0

    interface Serial0/0/0
    description ISP to HQ
    shut
    no ip address
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clock rate 64000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 122 interface Serial0/0/1 221
    frame-relay route 123 interface Serial0/2/0 321
    no shut
    !

    interface Serial0/0/1
    description ISP to BR1
    shut
    no ip address
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clock rate 64000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 221 interface Serial0/0/0 122
    no shut

    interface Serial0/2/0
    description ISP to BR2
    shut
    no ip address
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clock rate 64000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 321 interface Serial0/0/0 123
    no shut
    +++++++++++++++++++++++++++++++++++++++
    R1-Router
    =========
    default interface Serial0/0/0
    interface Serial0/0/0
    shut
    ip address 172.16.10.1 255.255.255.0
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    no fair-queue
    frame-relay map ip 172.16.10.2 122 broadcast
    frame-relay map ip 172.16.10.3 123 broadcast
    no frame-relay inverse-arp
    no shut

    R2-Router
    =========
    default interface Serial0/0/0
    interface Serial0/0/0
    shut
    ip address 172.16.10.2 255.255.255.0
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    no fair-queue
    frame-relay map ip 172.16.10.1 221 broadcast
    frame-relay map ip 172.16.10.3 221 broadcast
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    no shut

    R3-Router
    =========
    default interface Serial0/0/0
    interface Serial0/0/0
    shut
    ip address 172.16.10.3 255.255.255.0
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    no fair-queue
    frame-relay map ip 172.16.10.1 321 broadcast
    frame-relay map ip 172.16.10.2 321 broadcast
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    no shut

    Thanks,
    Owais Siddiqui

    • Sandeepdalal2000

      @Owais Siddiqui@2c9aebf2bd951a6ee281a97713a5a24a:disqus use
      no frame-relay lmi-type ansi

  • http://www.nish.com Nish Vamadevan

    Is the cable connected correctly and the clocking is set correctly on the interfaces? Use the “show controllers” command to find out which is the DTC/DCE end and set the clocking correctly.

  • Calin

    Very well explained, thank you!

    • http://www.nish.com Nish Vamadevan

      Thank you Calin, glad you liked the post.

  • Pingback: Frame-relay | Our CCNA study Notes()

  • Omar Hassan

    Shouldn’t the line “On R3: DLCI 321 is connected to R3.” be “On R3: DLCI 321 is connected to R1.” ??

    • http://www.nish.com/ Nish Vamadevan

      Thanks Omar, it is a typo and I have corrected it.

Next post:

Previous post: